MX2 on ATRIX Lapdock.

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Sun Jan 06, 2013 3:00 am

micl9 wrote:Great thread guys!
I can get the MX2 to work with my atrix 4g dock using just an HDMI and this http://www.amazon.com/gp/product/B007RFRHIY/ref=oh_details_o02_s00_i00 usb cable (don't think its OTG).
The USB is going between the male dock USB and the OTG port on the MX2. I get power and touchpad/keybd work.
But I have the crappy resolution selection. With this set up I cannot boot with the lid closed - blue light comes on and I can hear the speakers pop, but when I open the lid it looks like the dock cuts power and the turns it on again.

Question - why do you need to use the dock std USB port to power the MX2? Does the OTG cable disable the ability of the OTG port to power the MX2?



The MX2 currently needs the 5v to POWER the device FIRST then also you need the OTG to enable keyboard and track-pad.

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Sun Jan 06, 2013 3:01 am

I started a blog to consolidate my lapdock adventures : http://lapdockmod.blogspot.com/

micl9
Posts: 3
Joined: Mon Dec 17, 2012 10:43 pm

Re: MX2 on ATRIX Lapdock.

Postby micl9 » Sun Jan 06, 2013 10:02 am

PMMIKE wrote:The MX2 currently needs the 5v to POWER the device FIRST then also you need the OTG to enable keyboard and track-pad.

So your USB A cable is 2-wire/power only? I think I tried hooking a data cable up that way w/o the OTG cable and still could not boot up with the additional resolutions.

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Sun Jan 06, 2013 5:41 pm

micl9 wrote:
PMMIKE wrote:The MX2 currently needs the 5v to POWER the device FIRST then also you need the OTG to enable keyboard and track-pad.

So your USB A cable is 2-wire/power only? I think I tried hooking a data cable up that way w/o the OTG cable and still could not boot up with the additional resolutions.



Did you connect everything while the lid was closed and wait 5-10 seconds after blue light comes on MX2? ( see previous posts )

Btw I solved my issue see: http://lapdockmod.blogspot.com/

micl9
Posts: 3
Joined: Mon Dec 17, 2012 10:43 pm

Re: MX2 on ATRIX Lapdock.

Postby micl9 » Sun Jan 06, 2013 6:45 pm

OK - got it to work!
Here is how I am connected. The key is having both USB cables attached.
iMotoAtrix.jpg

Screen resolution can be corrected AND keybd and touchpad work! :mrgreen:

Note:
Neither cable I am using is an OTG cable, but I am not 100% sure on the micro female to micro male - it may be OTG.

What I discovered was that when using only the micro USB dock hook up - it has power when the lapdock is open or closed BUT it toggles off briefly when you open the dock. When using the USB A only it only has power when the lapdock is open and of course you have no keybd functionality.
When using BOTH cables the iMoto can boot with power from the micro USB dock allowing the wait of 5-10 sec (as PMMIKE indicated) and when you open the dock the USB A power comes on before the micro USB dock power toggles off.

My only remaining question is why you guys had to make all the custom cables?

Thanks for the help PMMIKE!
You do not have the required permissions to view the files attached to this post.

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Sun Jan 06, 2013 7:38 pm

micl9 wrote:OK - got it to work!
Here is how I am connected. The key is having both USB cables attached.
iMotoAtrix.jpg

Screen resolution can be corrected AND keybd and touchpad work! :mrgreen:

Note:
Neither cable I am using is an OTG cable, but I am not 100% sure on the micro female to micro male - it may be OTG.

What I discovered was that when using only the micro USB dock hook up - it has power when the lapdock is open or closed BUT it toggles off briefly when you open the dock. When using the USB A only it only has power when the lapdock is open and of course you have no keybd functionality.
When using BOTH cables the iMoto can boot with power from the micro USB dock allowing the wait of 5-10 sec (as PMMIKE indicated) and when you open the dock the USB A power comes on before the micro USB dock power toggles off.

My only remaining question is why you guys had to make all the custom cables?

Thanks for the help PMMIKE!


Awesome, no problem.

some MICRO-USB cables have 5 pins but the 4th (sense) pin is not connected.

lexan76
Posts: 29
Joined: Tue Dec 25, 2012 5:15 pm

Re: Sv: MX2 on ATRIX Lapdock.

Postby lexan76 » Mon Jan 07, 2013 4:08 pm

PMMIKE wrote:This is a nice cheap platform for the MX2!
Image Image Image
However, I have an issue with the MX2 and the lapdock.

The MX2 is not reading the full HDMI range of resolutions on the lapdock it is being connected to.
Image

The only way to get it to read it correctly is it FIRST externally power up the MX2 VIA the DC-5V or the MICRO USB port. THEN physically connect the stick to the lapdock via HDMI.
Image

This might be due to the adapters I am using? I have more physical connectors coming in. ( Anyone care to comment if they are running the same setup? )
Image Image

I thought it was the stock ROM that was limiting me so I jumped on the Finless ROM Flash Tool. Finless bob 1.5 with 1080P and 720P options.
( the Physical LCD of the Lapdock is 1280x672 PPI 160 )

This did not change the fuzzy letters ( see below image ) and quality of the screen. The Multi-step physicaly boot up did.
Image



THE end issue is that you CANNOT to my understanding boot the MX2 Via lapdock until the HDMI is connected. So basically you are stuck with shit 2 option fuzzy resolution. Unless you power from and external source.


Hej pmmike

You mention fuzzy letters, how did you fix this?
I think my desktop and all on my TV is a bit bluegrass and not as sharp as it should be.
Could it be you have had my problem?

Fredrik

Skickat från min Transformer TF101 via Tapatalk 2

edwardng
Posts: 1
Joined: Tue Jan 08, 2013 11:42 am

Re: MX2 on ATRIX Lapdock.

Postby edwardng » Tue Jan 08, 2013 12:27 pm

I dont understand the wiring...

To Power the stick, why not we try to use +5 port by hooking up a microusb to usb instead of using usb to usb??

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Wed Jan 09, 2013 10:20 am

edwardng wrote:I dont understand the wiring...

To Power the stick, why not we try to use +5 port by hooking up a microusb to usb instead of using usb to usb??

you can, thats what I do, I did not have one at the time. I do now :

Image

PMMIKE
Posts: 30
Joined: Sun Dec 23, 2012 1:18 am

Re: MX2 on ATRIX Lapdock.

Postby PMMIKE » Wed Jan 09, 2013 11:16 am

micl9 wrote:OK - got it to work!
Here is how I am connected. The key is having both USB cables attached.
iMotoAtrix.jpg

Screen resolution can be corrected AND keybd and touchpad work! :mrgreen:

Note:
Neither cable I am using is an OTG cable, but I am not 100% sure on the micro female to micro male - it may be OTG.

What I discovered was that when using only the micro USB dock hook up - it has power when the lapdock is open or closed BUT it toggles off briefly when you open the dock. When using the USB A only it only has power when the lapdock is open and of course you have no keybd functionality.
When using BOTH cables the iMoto can boot with power from the micro USB dock allowing the wait of 5-10 sec (as PMMIKE indicated) and when you open the dock the USB A power comes on before the micro USB dock power toggles off.

My only remaining question is why you guys had to make all the custom cables?

Thanks for the help PMMIKE!


where did you buy the Micro USB Female to Micro USB Male cable? Link ? - The one that makes the keyboard/mouse work ( plugged into the Male MICRO USB on the Cradle )

buzz86us
Posts: 36
Joined: Wed Dec 26, 2012 8:30 am

Re: MX2 on ATRIX Lapdock.

Postby buzz86us » Tue Jan 29, 2013 9:40 pm

micl9 wrote:OK - got it to work!
Here is how I am connected. The key is having both USB cables attached.
iMotoAtrix.jpg

Screen resolution can be corrected AND keybd and touchpad work! :mrgreen:

Note:
Neither cable I am using is an OTG cable, but I am not 100% sure on the micro female to micro male - it may be OTG.

What I discovered was that when using only the micro USB dock hook up - it has power when the lapdock is open or closed BUT it toggles off briefly when you open the dock. When using the USB A only it only has power when the lapdock is open and of course you have no keybd functionality.
When using BOTH cables the iMoto can boot with power from the micro USB dock allowing the wait of 5-10 sec (as PMMIKE indicated) and when you open the dock the USB A power comes on before the micro USB dock power toggles off.

My only remaining question is why you guys had to make all the custom cables?

Thanks for the help PMMIKE!

great solution worked great for my MK808 now I just have to flash this back to finless I was scared to try it your way for fear of shorting it out. Now I just need to get a mini-hdmi male to micro hdmi female adapter and this can be more mobile (included cord is very fat). Then I have to add linux and this will be the perfect machine.

buzz86us
Posts: 36
Joined: Wed Dec 26, 2012 8:30 am

Re: MX2 on ATRIX Lapdock.

Postby buzz86us » Fri Feb 15, 2013 11:09 am

I bought a mini usb to micro usb cable for this use but I decided to just use my micro usb female to full usb female cable and just use a usb power source to boot via the OTG before the lid is up since the trackpad is so finicky I am thinking it is due to a loose usb connection...

phreon
Posts: 11
Joined: Mon Dec 24, 2012 7:09 pm

Re: MX2 on ATRIX Lapdock.

Postby phreon » Sun Mar 24, 2013 10:57 am

I just noticed there is a Lapdock and Imito MX2 on ebay as a bundle with all the connectors and otg cables. Seller shows the working system in the pics and is in the usa so maybe I don't have to wait 30 days to get it. :)
Maybe this is the easy way but it does take the fun out of building your own.


Return to “MX2”

Who is online

Users browsing this forum: No registered users and 1 guest