Stuck at "Imito MX Series" logo

Bakred
Posts: 1
Joined: Wed Dec 19, 2012 11:35 am

Stuck at "Imito MX Series" logo

Postby Bakred » Wed Dec 19, 2012 11:48 am

Hello (sorry for my bad english)

I plug my Imito MX with original AC Adpater for first time and the logo moves forever....

Solutions ? Thanks ;)

darkness
Posts: 22
Joined: Sun Dec 02, 2012 3:50 am

Re: Stuck at "Imito MX Series" logo

Postby darkness » Wed Dec 19, 2012 10:04 pm

I'm experiencing the same issue with my MX1. The only difference is that mine was working fine, then it recently became stuck at the startup screen.

Here's the full post of my issue:
viewtopic.php?f=76&t=786#p5618

darkness
Posts: 22
Joined: Sun Dec 02, 2012 3:50 am

Re: Stuck at "Imito MX Series" logo

Postby darkness » Thu Dec 20, 2012 2:56 am

I've tried tirelessly to flash the firmware, but since I hadn't gotten around to flashing the firmware, I haven't been successful.

The problem is that the procedure for flashing requires that I have USB debugging turned on. The default USB debugging setting, which I hadn't touched, is set to off. I can't get to that setting (step #3 here http://blog.geekbuying.com/index.php/20 ... -firmware/).

I've looked at alternate methods, such as the micro USB method, but AFAIK, that also requires that you've previous flashed your firmware. I've contacted GeekBuying but haven't received a response. I'm now asking for an RMA if the problem can't be fixed.

If someone on this board has flashed firmware to the MX1 with USB debugging set to off, can you help a brother out? Instructions or a link to instructions would be appreciated. I've tried these instructions viewtopic.php?t=502&p=3035#p5048 these instructions http://blog.geekbuying.com/index.php/20 ... -firmware/ and also looked at viewtopic.php?f=78&t=684
None of these have worked successfully. :cry:

Kzn
Posts: 2
Joined: Mon Dec 24, 2012 3:00 am

Re: Stuck at "Imito MX Series" logo

Postby Kzn » Mon Dec 24, 2012 3:09 am

I received my key 2 days ago, it never booted properly. The 1st time, I saw a weird home, so I unplugged it. Since then it always stuck at the imito mx series logo.

So I couldn't switch the usb debuggingmode on

I followed this post viewtopic.php?f=76&t=502#p5048 and it worked. It may take time, for example windows took 3-4 min to recognize the key and ask me the driver, when I use Rockchip, At 1st the square is pink, i have to wait again 2-3 min, it changes to green. I also used the last firmware.
(I use my old netbook with windows xp to flash my key)

Just in case, like me, when you use Rockchip, it's in chinese, just click on the 1st button , it,s the language button and choose the 2nd option, it will be in english. Way easier !

Hope it helps :mrgreen:

darkness
Posts: 22
Joined: Sun Dec 02, 2012 3:50 am

Re: Stuck at "Imito MX Series" logo

Postby darkness » Wed Dec 26, 2012 7:43 pm

Hey kzn,

Thanks for reporting that you had got it working after encountering the same issue. I have mine working now, too!

I went back and tried the instructions you sent. It didn't work at first. I'm running Windows 7 64 bit, and the drivers for Intel are 32 bit. After some research on forums for the Rockchip drivers, I found a post from someone that had it working with a 64 bit Intel processor. You simply use the AMD 64 bit drivers. Once I managed that part, I loaded the software and switched to English, the rest of the steps worked flawlessly. Thanks for showing us how to toggle language!

Have the new 1080p firmware and it's been running pretty good with only a few minor issues like Chrome browser stability.

masifh
Posts: 5
Joined: Fri Feb 22, 2013 8:23 am

Re: Stuck at "Imito MX Series" logo

Postby masifh » Sat Jul 27, 2013 9:34 am

Dear KZn and Darkness,

I read your reviews and its seems your problem is similar like me ..

Actually my Imito MX 1 was working fine for last 2-3 months , it was turned on through out so u just need to tune tv to access this , last week i saw weird problem that its is not detecting WLan connection as i am using Wlan via USB jack, so i unplugged it and plug it again to reboot it (as unfortunately this device don't have a soft / plug to set the device off / on ) but it add to my surprise that the device stuck at Imito Mx1 boot logo and didn't proceed any further....so i decide to update the firmware using my Laptop (i have Acer with Window 7 Prem, 64 bit OS) as under:
1- when i connect the device it was detected within 1-2 mon as rockchip, then i load the Rockchip batch tool v1.6 and the device shows as pink there as well so after this i disconnect the device from laptop
2- now i put the paper clip in the reset button and while pressing the clip connect the device to laptop via OTG and left the press immediately after connecting the OTG (blue light on in the device) but now no device detected even waiting for 5-10 min also there is no green color detected on Rockchip batch tool v1.6 (to reset the device i use the hole next to HDMI point using paper clip , at that time the only connection to device is with the OTG to USB with laptop) no HDMI connection with TV nor with AC power .

PS: as this was the first time i am updating firmware , i never had the USB debugging option on...can you please guide me if i can recover my device ....Appreciate your support in a layman style as i m rookie on these sort of things.....
Cheers


Return to “MX1”

Who is online

Users browsing this forum: No registered users and 1 guest