MK808 Chaos about LAN->USB adapter

jaxx
Posts: 5
Joined: Tue Dec 11, 2012 10:35 am

MK808 Chaos about LAN->USB adapter

Postby jaxx » Tue Dec 11, 2012 11:53 am

All Folks ~ Please help me
I got the MK808 on Monday (2012/12/10)
I also have the WiFi too slow issue .
So I bought the LAN->USB adapter for the Ethernet .

But it has not WORK !!! That Driver me crazy for all night .
Image
https://www.dropbox.com/s/apxur9mkqggr8rn/1.jpg

my layout
Image
https://www.dropbox.com/s/vtp5y8oilry82v3/2.jpg

my mk808 information
Image
https://www.dropbox.com/s/1tm9pef4xg3atnm/5.jpg

my confused IP setting
Image
https://www.dropbox.com/s/qybzdk7it59roen/3.jpg


Could you please help to help me and explain some questions as below :

1.Do I need to setup the static IP setting for the Ethernet ?
2.What is symptom of normal connect with Mk808 and LAN->USB adapter ?
3.Does the LAN->USB adapter product cause no connect ?
4.Should I root the mk808 for this Ethernet request ?

csgabe
Posts: 29
Joined: Wed Nov 14, 2012 5:23 pm

Re: MK808 Chaos about LAN->USB adapter

Postby csgabe » Tue Dec 11, 2012 3:24 pm

Try setting 8.8.8.8 & 8.8.4.4 as DNS servers.

jaxx
Posts: 5
Joined: Tue Dec 11, 2012 10:35 am

Re: MK808 Chaos about LAN->USB adapter

Postby jaxx » Tue Dec 11, 2012 10:54 pm

csgabe wrote:Try setting 8.8.8.8 & 8.8.4.4 as DNS servers.


Is my Lan->usb adapter normal ?

I want to Returns my Lan->usb adapter today,
I had found some bid of mk808 Lan->usb adapter
http://goods.ruten.com.tw/item/qa?21211225960203
http://goods.ruten.com.tw/item/show?21212080800947

So confused about the adapter or my static IP setting ????????

csgabe
Posts: 29
Joined: Wed Nov 14, 2012 5:23 pm

Re: MK808 Chaos about LAN->USB adapter

Postby csgabe » Wed Dec 12, 2012 4:06 am

Is my Lan->usb adapter normal ?

I don't know. What chipset does it have? You could try installing terminal emulator & see that when you plug in the adapter what is the output of "dmesg" command.

ADD
Posts: 11
Joined: Mon Dec 03, 2012 12:10 pm

Re: MK808 Chaos about LAN->USB adapter

Postby ADD » Wed Dec 12, 2012 11:20 am

jaxx wrote:Is my Lan->usb adapter normal ?

I want to Returns my Lan->usb adapter today,
I had found some bid of mk808 Lan->usb adapter
http://goods.ruten.com.tw/item/qa?21211225960203
http://goods.ruten.com.tw/item/show?21212080800947

So confused about the adapter or my static IP setting ????????

Easy, my friend ;) It seems that your adapter is well recognized, otherwise it would not let you switch ethernet on. First of all, try to change your IP to 192.168.1.39 for example and see if the network icon in status bar changes from white to blue.

Good luck!

jaxx
Posts: 5
Joined: Tue Dec 11, 2012 10:35 am

Re: MK808 Chaos about LAN->USB adapter

Postby jaxx » Mon Dec 17, 2012 8:03 am

ADD wrote:
jaxx wrote:Is my Lan->usb adapter normal ?

I want to Returns my Lan->usb adapter today,
I had found some bid of mk808 Lan->usb adapter
http://goods.ruten.com.tw/item/qa?21211225960203
http://goods.ruten.com.tw/item/show?21212080800947

So confused about the adapter or my static IP setting ????????

Easy, my friend ;) It seems that your adapter is well recognized, otherwise it would not let you switch ethernet on. First of all, try to change your IP to 192.168.1.39 for example and see if the network icon in status bar changes from white to blue.

Good luck!




IT is WORKING !!!!!!!!!!!!!!!!!!!!!!!!
after setting the static IP that nice guys told as below :
https://www.dropbox.com/s/8urjvg0zross0y6/Screenshot.png
https://www.dropbox.com/s/8urjvg0zross0 ... enshot.png

I have fun ll day , THanks guys , Thanks ArmTvTech.com
:lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol:

johneliot1978
Posts: 26
Joined: Tue Nov 27, 2012 4:31 pm

Re: MK808 Chaos about LAN->USB adapter

Postby johneliot1978 » Tue Dec 18, 2012 5:46 pm

I have the same problem, but my network is all 10.1.1.x setup. Does that mean the only way I can get the usb2rj45 working is to change my whole network config to be 192.168.1.x?

This is probably more a networking question :) but can I have the static ip on the dongle set to 192.168.1.39 and connecting to a router which is 10.1.1.1? It just won't work, right?

Cheers,
John <-- networking n00b!

ADD
Posts: 11
Joined: Mon Dec 03, 2012 12:10 pm

Re: MK808 Chaos about LAN->USB adapter

Postby ADD » Wed Dec 19, 2012 9:54 am

johneliot1978 wrote:I have the same problem, but my network is all 10.1.1.x setup. Does that mean the only way I can get the usb2rj45 working is to change my whole network config to be 192.168.1.x?

This is probably more a networking question :) but can I have the static ip on the dongle set to 192.168.1.39 and connecting to a router which is 10.1.1.1? It just won't work, right?

Cheers,
John <-- networking n00b!

I'm not sure about the IP pool in your case, but try to set your IP to 10.1.1.2(or 3,4,5...) with gateway 10.1.1.1 and netmask 255.255.255.0 in static IP settings.

johneliot1978
Posts: 26
Joined: Tue Nov 27, 2012 4:31 pm

Re: MK808 Chaos about LAN->USB adapter

Postby johneliot1978 » Wed Dec 19, 2012 9:34 pm

yeah, have given that a go already with no joy. what i found using this usb2rj45 on a windows 7 PC was pretty much the same thing, it just didn't work for dhcp, and static settings did nothing. The only way i could get it working for dhcp and any static settings i wanted was to go into the driver settings and toggle the Media Type off Auto Negotiation and the only one that worked was either (10half-duplex,10full-duplex) cant remember which, but none of the ones you would think ie 100half-duplex,100full-duplex, or Auto Negotiation.

of course i have no idea how to fiddle these sort of settings in android, there certainly isn't anything in the settings app and haven't looked at console commands to achieve the same... i suspect the thing is just a piece of crap to be honest! :( most sad. I know other folks have said, go for the slightly more expensive ~$10buck variants that are 100% plug and play and don't need drivers in windows, and they seem to work a lot better!

jaxx
Posts: 5
Joined: Tue Dec 11, 2012 10:35 am

Re: MK808 Chaos about LAN->USB adapter

Postby jaxx » Wed Dec 19, 2012 11:44 pm

johneliot1978 wrote:yeah, have given that a go already with no joy. what i found using this usb2rj45 on a windows 7 PC was pretty much the same thing, it just didn't work for dhcp, and static settings did nothing. The only way i could get it working for dhcp and any static settings i wanted was to go into the driver settings and toggle the Media Type off Auto Negotiation and the only one that worked was either (10half-duplex,10full-duplex) cant remember which, but none of the ones you would think ie 100half-duplex,100full-duplex, or Auto Negotiation.

of course i have no idea how to fiddle these sort of settings in android, there certainly isn't anything in the settings app and haven't looked at console commands to achieve the same... i suspect the thing is just a piece of crap to be honest! :( most sad. I know other folks have said, go for the slightly more expensive ~$10buck variants that are 100% plug and play and don't need drivers in windows, and they seem to work a lot better!



Change a new LAN->USB adaptoe is a good solution .

johneliot1978
Posts: 26
Joined: Tue Nov 27, 2012 4:31 pm

Re: MK808 Chaos about LAN->USB adapter

Postby johneliot1978 » Thu Dec 20, 2012 1:02 am

Change a new LAN->USB adaptoe is a good solution .[/quote]

Can you recommend one that works fine for you on the mk808 ? ( and isnt to exy? )

ADD
Posts: 11
Joined: Mon Dec 03, 2012 12:10 pm

Re: MK808 Chaos about LAN->USB adapter

Postby ADD » Thu Dec 20, 2012 6:35 am

johneliot1978 wrote:Change a new LAN->USB adaptoe is a good solution .


Can you recommend one that works fine for you on the mk808 ? ( and isnt to exy? )[/quote]

I'd recommend the one I recently bought here
It works at full USB2.0 speed (I get my internet bandwith at full), plug&play, black color, rather cheap, the blinking red diod is not that annoying like on other "xmas trees" (just face it down or away).

But before going for the new one, tell me, is your old one recognized by the android stick? I mean, does the ethernet switch stay on and you see the ethernet icon in the status bar (bottom right corner of the screen)?

Cheers

johneliot1978
Posts: 26
Joined: Tue Nov 27, 2012 4:31 pm

Re: MK808 Chaos about LAN->USB adapter

Postby johneliot1978 » Thu Dec 20, 2012 7:25 am

you must be magic man :/
just went to try plug in the usb2rj45 and grab some dmesg logs and whatnot and checked for the ethernet icon etc. and its working?! ???

perhaphs i had too many things plugged in to the usb hub when i was trying before? this is probably the first time ive tried it with just the wirelsss kbd dongle and the ethernet adapter? how many things can you stack on a hub going into the OTG port? i just figured you could add as many as you wanted? but perhaphs not...

anyway, thanks for getting back to me! :) you inadvertently solved my problem :)

Cheers!
John

ADD
Posts: 11
Joined: Mon Dec 03, 2012 12:10 pm

Re: MK808 Chaos about LAN->USB adapter

Postby ADD » Thu Dec 20, 2012 10:32 am

johneliot1978 wrote:you must be magic man :/
just went to try plug in the usb2rj45 and grab some dmesg logs and whatnot and checked for the ethernet icon etc. and its working?! ???

perhaphs i had too many things plugged in to the usb hub when i was trying before? this is probably the first time ive tried it with just the wirelsss kbd dongle and the ethernet adapter? how many things can you stack on a hub going into the OTG port? i just figured you could add as many as you wanted? but perhaphs not...

anyway, thanks for getting back to me! :) you inadvertently solved my problem :)

Cheers!
John


Happy for you man! Normally, I have a mouse and a non-powered HDD connected to my device. But as soon as I switch WiFi on it drops the harddrive. So, better use the powered hub. Don't buy those sheap chinese ones, go for a named brand. I got D-Link DUB-H4. Very good one.

Enjoy!

player911
Posts: 52
Joined: Mon Dec 03, 2012 4:58 pm

Re: MK808 Chaos about LAN->USB adapter

Postby player911 » Thu Dec 20, 2012 10:30 pm

I had an old NetGear FA120 USB-LAN Adapter that I've owned since the late 90's. I plugged it up and away it went. I doubt you can still buy these, new at least.

jaxx
Posts: 5
Joined: Tue Dec 11, 2012 10:35 am

Re: MK808 Chaos about LAN->USB adapter

Postby jaxx » Thu Dec 20, 2012 11:38 pm


ADD
Posts: 11
Joined: Mon Dec 03, 2012 12:10 pm

Re: MK808 Chaos about LAN->USB adapter

Postby ADD » Fri Dec 21, 2012 11:01 am

player911 wrote:I had an old NetGear FA120 USB-LAN Adapter that I've owned since the late 90's. I plugged it up and away it went. I doubt you can still buy these, new at least.

This is weird :o Are you sure you're getting full USB2.0 speed on that one? Try to test it by using the speedtest app or directly on speedtest.net.

jaxx wrote:http://goods.ruten.com.tw/item/qa?21211225960203

I have used this type

That's the good one which uses the correct ASIX chipset

notkool
Posts: 1
Joined: Fri Apr 11, 2014 8:44 am

Re: MK808 Chaos about LAN->USB adapter

Postby notkool » Fri Apr 11, 2014 8:57 am

hi guys

i am so happy to find this here.
i have trouble setting up lan connection with mk808 on my tv.
wifi works fine.
i want to fix this so i can watch xbmc.

here are pictures of how the settings are made on my tv.
i really hope you can help me solve this :)
thanks in advance guys.
rachel

http://postimg.org/gallery/2uxczrbj8/

i am using this usb to lan adaptor
http://www.kgg.co.th/thumb/thumb.php?fi ... mbsize=304


Return to “MK808”

Who is online

Users browsing this forum: No registered users and 6 guests