MK808 + Finless ROM 2.1 + External Wifi

saperos
Posts: 5
Joined: Fri Sep 27, 2013 1:48 am

MK808 + Finless ROM 2.1 + External Wifi

Postby saperos » Wed Oct 02, 2013 4:11 pm

Hello Friends,

I am starting this topic as I read tons of other ones, lost 3 days already and still can't get my wifi dongle to work...

OK, so I bought a usb wifi based on Ralink RT5370 (sth like this) as I somehow found out that there are drivers for it. Before buying I even found a rom (by lewy20041) that had this drivers built in and which should work out of the box. It did not

So then I found information that FInless 2.1 also has those drivers. I flashed it, and found several ko files related to RT5370. I followed this solution:

Code: Select all

1. turn off wifi
2. copy rt5370sta,ko to /system/lib/module/ (I of course skipped that as files were already there :))
3. rename rkwifi.ko to other name, say, rkwifi.ko.bak
4. rename rt5370ta.ko to rkwifi.ko (also ensure you get the right permissions setting)
5. plug your usb wifi to mk808
6. turn on wifi


I tried that with all files I found in /system/lib/modules that had RT5370 in name, but wifi ever turned on (just to note, I changed name on wifi turned off, restarted device after every change and tried OTG and normal usb ports) When I then tried to turn on wifi it automatically was turning off.

I am very kindly asking for help. I know that I am missing something really simple.

I know lots of you managed to successfully get usb wifi dongles to work, I hope someone will be kind enough to share instructions with desperate Linux noob

I bought this device so that my family can browse internet while main pc is occupied, and now this functionality is not working...

BR,
Kuba

Return to “MK808”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests