Problem with keyboard and mouse

sdspieg
Posts: 8
Joined: Tue Dec 25, 2012 9:56 pm

Problem with keyboard and mouse

Postby sdspieg » Sat Jan 26, 2013 8:49 am

UPDATE - For some reason, it DOES not all seem to work. Sometimes they say you have to let a new ROM 'settle' for a while - maybe this was sthg similar. At any rate: I am fully functional now, rooted, droidmote now DOES work - so let the fun times commence! :D

I got my hi802 (presumably the same hardware as the GK802) yesterday. I played around with the stock firmware for a day and everything worked fine. Today I decided to root the device and I used the last firmware I found on this forum (rooted_fixed_rt-M500a_v1.65.4_20130118a_updated). Getting into recovery worked fine once I realized that a) I had to keep the button pushed in until the logo appeared and then had to let go; and b) that the power usb hub I used wasn't recognized in recovery mode, and that I had to plug my usb keyboard directly into the usb-port of the device. Once I realized that, I could move the cursor, select the right option and flash the new firmware. So Android boots up fine now, but I seem unable to do anything anymore: neither keyboard nor wireless mouse work - not via the powered hub, nor when I plug them directly into the hdmi-stick. Does anybody have any ideas what I can do? Thanks much.

rkelly
Posts: 10
Joined: Tue Jan 15, 2013 11:07 am

Re: Problem with keyboard and mouse

Postby rkelly » Sun Jan 27, 2013 7:13 am

I guess the only thing you can do is use another keyboard/mouse.
My Logitech K400 works fine while in recovery mode.
There is also a thread on this board about supported keyboards and mice.
GK802 (Presumably 1st version)

werttrewis
Posts: 5
Joined: Fri Jan 11, 2013 5:55 am

Re: Problem with keyboard and mouse

Postby werttrewis » Tue Jan 29, 2013 8:36 am

I also have a HI802 which schould be the same as the GK802.

The HI802 seems to have some weired problems with its integrated usb:

On the HI802 I can use any keyboard/mouse without any problems, but can't use any mass storage devices.
They get recogniced, but show up as emty and can't be mounted (have tested all apps).
Active usb-hubs also don't seem to work as they should, passive ones work for me.
Also the HI802 seems to be very selective to which PSU and usb to micro usb cable you use.
If you don't use the right combination(my HI802 was delivered with the wrong PSU and a proprietary cable and i have spend about a week to find the right combination), no peripherals on the usb work.
Also the new patch at HIAPAD.COM (u-boot-no-padding.bin) doesn't work for me, nothing changed

beljim7419
Posts: 1
Joined: Thu Jan 31, 2013 6:08 pm

Re: Problem with keyboard and mouse

Postby beljim7419 » Thu Jan 31, 2013 6:13 pm

I found that my wireless fly remote would not work unless I used the supplied power plug. I think they have made them different to others for some bizzar reason. They probably think it's going to stop copies being made.

momochan
Posts: 43
Joined: Fri Dec 28, 2012 4:43 pm

Re: Problem with keyboard and mouse

Postby momochan » Thu Jan 31, 2013 11:15 pm

beljim7419 wrote:I found that my wireless fly remote would not work unless I used the supplied power plug. I think they have made them different to others for some bizzar reason. They probably think it's going to stop copies being made.


I just realized the same thing. My setup consists of a GK802, a 7-port D-Link powered hub and a Measy RC11 fly remote. The RC11 works with or without the hub and original LA-520W power supply. I decided to purchase a spare LA-520 USB power supply on Geekbuying because they state it works with all TV boxes (this power supply doesn't have the built-in micro-usb cable so I used the GK-802's USB2.0 to micro-usb cable and a Blackberry USB2.0 to micro-USB cable). Unfortunately, this power supply does not work with the RC11 fly remote, hub or no hub. The only peripheral that does work with this power supply is a wired mouse.

We really need to press Geekbuying to sell the "original" LA-520W as a separate item. Despite nearly the same model number, the LA-520 doesn't power the RC11 remote.

dylandn had something interesting to say about these power supplies over here:
viewtopic.php?f=4&t=1294

werttrewis
Posts: 5
Joined: Fri Jan 11, 2013 5:55 am

Re: Problem with keyboard and mouse

Postby werttrewis » Fri Feb 01, 2013 11:15 am

I stumbled over a very intersting post here: viewtopic.php?f=4&t=1294

Maybe the LA-520W has the two data-pins connected and that makes it different from a normal charger?

I also have a lot of problems with my HI802, that was delivered with a charger that doesn't work with the HI802.

Maybe somebody who has got the original LA-520W with his GK802 and has a ohm-meter can confirm that the two data-pins are connected?
That would make it very simple for a lot of people to modify their power-supply to work with the HI802/GK802!

momochan
Posts: 43
Joined: Fri Dec 28, 2012 4:43 pm

Re: Problem with keyboard and mouse

Postby momochan » Sun Feb 17, 2013 6:30 pm

werttrewis wrote:I stumbled over a very intersting post here: viewtopic.php?f=4&t=1294

Maybe the LA-520W has the two data-pins connected and that makes it different from a normal charger?

I also have a lot of problems with my HI802, that was delivered with a charger that doesn't work with the HI802.

Maybe somebody who has got the original LA-520W with his GK802 and has a ohm-meter can confirm that the two data-pins are connected?
That would make it very simple for a lot of people to modify their power-supply to work with the HI802/GK802!



I did some testing on the LA-520 power supply. I'll start a new thread on it over in the Hardware Mods section.

jonsey
Posts: 36
Joined: Fri Dec 14, 2012 10:46 am

Re: Problem with keyboard and mouse

Postby jonsey » Sat Feb 23, 2013 5:56 am

i've Logitech k700...AWESOME!All perfect! ;)


Return to “Firmware”

Who is online

Users browsing this forum: No registered users and 1 guest