Anybody got USB Camera working?

koral
Posts: 3
Joined: Tue May 14, 2013 3:35 am

Anybody got USB Camera working?

Postby koral » Tue May 14, 2013 3:44 am

Hi All, I'm running 4.2.2 but there seems to be no camera support.

I rooted and checked the kernel messages to dig the problem down - I believe it's due to the lack of the 'uvcvideo' module. Anybody knows how I can get it?
(by comparison, the same camera is working on my mk802, with the latest firmware with camera support)

Thanks to everybody that can provide any info!
/E

fwupow
Posts: 33
Joined: Sat Jan 05, 2013 12:53 am

Re: Anybody got USB Camera working?

Postby fwupow » Fri May 17, 2013 10:56 pm

Ya, same story everybody. Geekbuying is forecasting new firmware from Tronsmart to fix this.
Half-baked firmware is de rigueur for all these HDMI sticks coming out of China it seems. I don't personally enjoy this fashionable practice. but what am I to do?

koral
Posts: 3
Joined: Tue May 14, 2013 3:35 am

Re: Anybody got USB Camera working?

Postby koral » Sat May 18, 2013 6:12 pm

Yeah, I'm figuring out. I agree that they should be a little more helpful/supportive -- not to mention releasing their source code as the Android (or linux kernel) license implies!

So, I've tried to build the 'uvcvideo' driver of the linux kernel (for rk3188) myself and to load it on the T428.
The system just locks up :/ (or at least the graphics, the rest of the system seems fine)

If they just included the 'uvcvideo' driver.. we'll have a ton of USB cameras working!

koral
Posts: 3
Joined: Tue May 14, 2013 3:35 am

Re: Anybody got USB Camera working?

Postby koral » Sat Jun 01, 2013 1:13 am

Guys - GREAT NEWS.

The latest Firmware (@see Tronsmart Website, or http://blog.geekbuying.com/index.php/20 ... oth-all-ok ) fixes my USB cam (and many others)

Thanks Geekbuying!


Return to “Tronsmart T428”

Who is online

Users browsing this forum: No registered users and 1 guest