USB2 socket refuses to allow charging properly.

MTK6589 quad core based phablet with a 4.7 inch 720p screen
gregzeng
Posts: 2
Joined: Mon Mar 10, 2014 10:54 am
Location: Australian Capital Territory

USB2 socket refuses to allow charging properly.

Postby gregzeng » Mon Mar 10, 2014 11:14 am

Google shows me that this USB2 design fault is common. Electrical contacts sometimes made by jiggling the (male) plug at a steady pressure & angle into the female socket.

Youtube videos show how to use fine-pointed needles to remove rubbish blocking the pins. Yet to try this.

Tried using camera-lens puffers, etc - to try to dislodge the rubbish. In my work-life decades ago, I was on an ISO-standards consultative committee in Australia. IMO the USB2 committee in the ISO was negligent in its recommendations. Similar to the committee I worked with in Australia.

Bought desoldering/ soldering gadgets, + spare female on-board sockets to try to reinstall the bad socket. Yet to do this; I'm so old and frail nowadays.

Any other solutions, anyone?

Return to “Jiayu G4”

Who is online

Users browsing this forum: No registered users and 1 guest