Prometheus vs. RK3066 Android Stick

Dual core Android set top box based on the AML8726M6 soc.
linuxslate.com
Posts: 7
Joined: Mon Mar 04, 2013 11:27 am

Prometheus vs. RK3066 Android Stick

Postby linuxslate.com » Mon Mar 04, 2013 11:40 pm

Sorry, but I have to join the list of complainers about this device.

I also have a RK3066 Android 4.1.1 HDMI stick (Jesurun NX003 - same as MX1), and there are a lot of things that work on my RK3066 stick that do not work on the Tronsmart Prometheus.

1. The Prometheus initially appeared DOA (Dead on Arival). I hooked it up to my TV via a good quality HDMI cable, connected the power supply, flipped the switch, and.... Nothing. I Tried numerous things - all of the TV's HDMI ports -- different HDMI cables, etc. My RK3066 works fine on the same TV, although I will grant that the TV seems to support only a few resolutions over HDMI. I then tried a smaller TV/Monitor via a DVI adapter -- again, a configuration that works fine (albeit no sound, as expected) with the RK3066 stick -- Still no output from the Prometheus at all.

I then tried composite video on the small TV. This produced an out-of sync image -i.e. perhaps PAL on an NTSC TV. While it was on, I switched to the HDMI port and --- A picture. In this configuration, I was able spot the problem. In Settings --> Display, it was set to a fixed resolution, instead of the setting that will allow it to automatically find the best resolution the display will support. I set it to automatic, and moved back to the big TV, and it worked fine --- Sort of -- Which brings me to complaint #2:

2. In 1080p mode, there is screen distortion. Minor, but irritating, and again the RK3066 stick does not have this problem on the same TV. Occasionally a tiny dotted line will appear across the screen (horizontal). It is instantaneous, but an obvious glitch. Worse than that the entire screen will occasionally flicker. Simply moving the cursor near the right side of the screen will cause this repeatedly. Setting it to 720p eliminates this problem. To be fair, due to the 720p to 1080p scaling that many of these devices do, I do not use either of them in 1080p mode, but if I do, the RK3066 stick does not have this problem.

3. Along with the Prometheus, I purchased a Measy RC13 Keyboard/Mouse/and wireless audio device combination. When connected to the RK3066, it appears in Settings --> Sound --> Sound device manager as both a sound input, and output device, and I can select them independently. In other words, I can use the mic in the RC13, and still have the sound come out the TV speakers.

The really cool part is that on the RK3066 stick, the RC13 mic works for voice searches, voice typing, and Google Wave. I can talk to Google Wave, and my TV talks back. Since the RC13 is in my hand, I do not have to yell across the room at the TV. Cool and convenient.

Unfortunately, the Prometheus does not recognize the audio functions of the RC13 at all. So none of the above works.

4. XBMC (Yes, "special Prometheus version", with newest firmware) is nearly useless to me. It has an awkward user interface, and it took several steps to find my MythTV Server (UPnP). Even once I added it, it would not play any of the videos. It would display a single frame in the lower right of the screen, but the play button disappears instantly, and I get a message telling me to check the logs. I did get it to play a slide show from pictures on my NAS (smb), but I could not find out how to change any settings (display time, effect, etc.). Swiping does not work to advance to the next picture. It worked only as a very primitive slide show viewer.

The RK3066K shipped with eHome Media Center pre-installed. This found my MythTV system with out me doing anything, and plays low-def recordings fine. HiDef Recordings are un-watchably slow. (In all cases mentioned here, both devices were connected via Ethernet. Yes, this requires a dongle on the RK3066 stick, but the first (and only) one I tired worked immediately, and connected to my network without me doing anything.

Instead of XBMC, I think they should have just called it BM.

5. Tronsmart's Firmware naming is almost incomprehensible. The download file name dates do not necessarily correlate to a kernel or build date once installed. On the Tronsmart download page, the FW file dates are not in any order. They are currently in this order:
20130125
20130129
20130118
Is it newest on top(which seems to be the newest post), or is 20130129 the latest?
Apparently, they are really the same, but the top one (with and older date) adds XBMC.
Where is 20130222?, which is on Geekbuying? is 20130222 on geek buying the same as 20130125 on Tronsmart's page? Are all of these really the same FW/Kernel, but just different, additional add-ons?
Why don't they put XBMC in the actual firmware, instead of telling you to install the same FW you already have, and then separately installing the .apk?
Very unprofessional.

6. I have not tried WiFi on the Prometheus. It may win this one since I had to do a modification to my RK3066 stick to add an external antenna, but that is somewhat trivial at this point since I use Ethernet on both. Also, according to some posts here, I am going to have to do a modification to the Prometheus to add a head sink.

I certainly hope Tronsmart fixes this soon (especially USB audio devices), but for now, my Prometheus is disconnected, and I am back to my RK3066 stick.

Edit: Fixed spelling errors.
Last edited by linuxslate.com on Tue Mar 05, 2013 1:56 pm, edited 1 time in total.

bert21
Posts: 12
Joined: Sun Feb 24, 2013 6:00 am

Re: Prometheus vs. RK3066 Android Stick

Postby bert21 » Tue Mar 05, 2013 4:53 am

hello

you are right about Tronsmart's Firmware naming.
i have tried all of Tronsmart's Firmware's
the Firmware file with the date 20130125 seems to be the newest, when it is unzipped the date is 2013-02-22
so the newest on top is 20130125, and that is the latest Firmware

the best result i get, is with Firmware bult 20130125
i use mxplayer pro v-1.7.10 and MediaHouse UPnP / DLNA-browser to stream movie’s to my tv
a 1080p movie play's full screen from wifi network and played very smooth.

xbmc is still unusable as a media player as video from the network wont start

my youtube app doesn't work with the 20130125 Firmware
that is the only thing i have problems with.
in any other builds it is ok
and in the browser youtube videos are playing fine
You do not have the required permissions to view the files attached to this post.


Return to “Tronsmart Prometheus”

Who is online

Users browsing this forum: No registered users and 2 guests