Issue updating to 4.1 - Device not recognised

Rickj
Posts: 21
Joined: Sat Nov 17, 2012 2:51 pm

Issue updating to 4.1 - Device not recognised

Postby Rickj » Mon Dec 03, 2012 10:21 am

Hi,

I am trying to update my x5 to Android 4.1 but my pc is not detecting the device so I cannot install the drivers.

I first connect my x5 to my pc using the OTG connector. Then press and hold in recover button. Then power on device. I wait for a few seconds and then the little android man appears lying down with his chest open and a bit read triangle with an exclamation mark appears. Then nothing. The device does not appear in windows (or even in linux).

Any ideas what I am doing wrong?

User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Mon Dec 03, 2012 11:40 am

Have you rooted it previously? Have you tested OTG port?

I can't root it because my pc does not detect anything from OTG port. :evil:

Rickj
Posts: 21
Joined: Sat Nov 17, 2012 2:51 pm

Re: Issue updating to 4.1 - Device not recognised

Postby Rickj » Mon Dec 03, 2012 11:56 am

jlcd wrote:Have you rooted it previously? Have you tested OTG port?

I can't root it because my pc does not detect anything from OTG port. :evil:


That sounds exactly like what is happening to me.

alwaysbless
Posts: 101
Joined: Sat Sep 29, 2012 5:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby alwaysbless » Mon Dec 03, 2012 12:07 pm

You guys need to enbable usb debugging in developer settings otherwise it will never get detected.


User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Mon Dec 03, 2012 12:10 pm

I have followed the instructions step by step, and I've tried several different cables...

alwaysbless
Posts: 101
Joined: Sat Sep 29, 2012 5:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby alwaysbless » Mon Dec 03, 2012 12:17 pm

jlcd wrote:I have followed the instructions step by step, and I've tried several different cables...


Hmm those directions worked for me.. I dont remember what order I booted it to work but it did take a few tries before it was recognized my moborobo. Try messing around with the sequence that you power it on with

Rickj
Posts: 21
Joined: Sat Nov 17, 2012 2:51 pm

Re: Issue updating to 4.1 - Device not recognised

Postby Rickj » Mon Dec 03, 2012 12:23 pm

alwaysbless wrote:You guys need to enbable usb debugging in developer settings otherwise it will never get detected.


Ok I've tried with the usb debugging enabled and disabled and also connect to pc enabled and disabled and still nothing.

Is the android guy with a red triangle supposed to show up?

alwaysbless
Posts: 101
Joined: Sat Sep 29, 2012 5:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby alwaysbless » Mon Dec 03, 2012 12:40 pm

I dont know I didnt have mine plugged into the tv at the same time as trying to root it..maybe thats why its not working for you

User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Mon Dec 03, 2012 8:00 pm

OTG port is not working properly. With the supplied cable is impossible to connect, I tried another cable and I managed to connect but intermittently. Thus it is impossible to root it nor firmware update.

User avatar
geekbuying
Posts: 492
Joined: Wed Sep 26, 2012 10:11 am
Contact:

Re: Issue updating to 4.1 - Device not recognised

Postby geekbuying » Mon Dec 03, 2012 10:53 pm

HI

i am here ,guys, when you post the tread,i am still at sleep :) just come back to office.

Yesterday i also met the problem, but i directly use my cell phone(HTC) cable,and try to root it in windows XP system, and the computer can find the device.

I will try to use the supplied cable, and try in different system to check.

I will report back soon.

and now all of the x5 release from factory has been upgrade to android 4.1 ics.

User avatar
geekbuying
Posts: 492
Joined: Wed Sep 26, 2012 10:11 am
Contact:

Re: Issue updating to 4.1 - Device not recognised

Postby geekbuying » Tue Dec 04, 2012 2:05 am

Hi guys, i am back

I just try the NEO X5 in my office, i use the usb cable in the package, here is what i have done:

1 connec the charger with neo x5;
2 insert the usb cable with neo x5 and my computer, my computer is windows 7 32 bit;
3 use a clip and insert to that" recovery"hole which near the HDMI port, and then press the power on button, then my computer will tell me a new device has been detected, and ask me to install the driver.

i test in different device, and both of them can work well. and i also report your questions to factory, they also will check for me.

any questions, feel free to ask.

thanks

User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Tue Dec 04, 2012 3:57 am

I think my problem is OTG port. I've tested on 2 PC and with 3 different cables, and If I try to connect via the USB-OTG cable, for example, a USB flash drive neither detects the X5.

I've found similar problem in a german forum

http://www.minix-forum.de/produkte/andr ... e/#post259

With a videocamera cable if I press strongly the connector against the box the pc detects a new device, but is an unstable connection and I can not finish the process.

Is there any other method to root/update X5 without OTG port? It's easy open the X5 housing?

User avatar
geekbuying
Posts: 492
Joined: Wed Sep 26, 2012 10:11 am
Contact:

Re: Issue updating to 4.1 - Device not recognised

Postby geekbuying » Tue Dec 04, 2012 5:54 am

jlcd wrote:I think my problem is OTG port. I've tested on 2 PC and with 3 different cables, and If I try to connect via the USB-OTG cable, for example, a USB flash drive neither detects the X5.

I've found similar problem in a german forum

http://www.minix-forum.de/produkte/andr ... e/#post259

With a videocamera cable if I press strongly the connector against the box the pc detects a new device, but is an unstable connection and I can not finish the process.

Is there any other method to root/update X5 without OTG port? It's easy open the X5 housing?

I will ask factory if we have other way to root it.

User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Tue Dec 04, 2012 6:07 am

Thanks Geekbuying. Finally I succeeded squeezing tightly against the connector housing. There must be some problem with that connector or placement in the box.

I'll see how I do for future updates...

Rickj
Posts: 21
Joined: Sat Nov 17, 2012 2:51 pm

Re: Issue updating to 4.1 - Device not recognised

Postby Rickj » Tue Dec 04, 2012 6:41 am

I finally got mine working as well.

It seems like the OTG slot is too deep and the micro usb connection cannot make a proper connection. What I did as cut off about 1mm of the black plastic around the micro usb connector and then it was able to correctly fit in the OTG slot and make a proper connection.

User avatar
geekbuying
Posts: 492
Joined: Wed Sep 26, 2012 10:11 am
Contact:

Re: Issue updating to 4.1 - Device not recognised

Postby geekbuying » Tue Dec 04, 2012 10:38 pm

HI

After we receive your report, we directly contact minix factory, and ask for solution.

i think we should make sure we are talking the same cable, in the X5 package, there are two cables, one is the micro usb to usb cable, one is the micro usb to female usb cable ( you guys call this as OTG cable???)

if you want to root or update the system, you should use the long micro usb to usb cable, not use that short micro usb to female usb cable.

please make sure you understand what i am saying.

and MINIX factory also tell us, they are building the OTA update server, so in future, you will update your MINIX online, do not use the OTG cable to do the update.

any other questions, please feel free to contact.

thanks

User avatar
geekbuying
Posts: 492
Joined: Wed Sep 26, 2012 10:11 am
Contact:

Re: Issue updating to 4.1 - Device not recognised

Postby geekbuying » Tue Dec 04, 2012 11:46 pm

Image

I attach a photo for you guys checking, you should use the micro usb to usb cable to connect with PC, do not use that OTG Cable.

User avatar
jlcd
Posts: 50
Joined: Sat Sep 22, 2012 1:23 pm

Re: Issue updating to 4.1 - Device not recognised

Postby jlcd » Wed Dec 05, 2012 4:28 am

Yes, I've been using that cable, but as Rickj says, OTG port slot is to deep for a good connection.

kenofstephen
Posts: 17
Joined: Wed Oct 31, 2012 12:55 pm

Re: Issue updating to 4.1 - Device not recognised

Postby kenofstephen » Wed Dec 05, 2012 10:35 am

jlcd wrote:OTG port is not working properly. With the supplied cable is impossible to connect, I tried another cable and I managed to connect but intermittently. Thus it is impossible to root it nor firmware update.


I upgraded 2pcs NEO X5 successfully with the supplied micro-usb cable connected to the PC.
I think it's something else causing the failure (no device driver installed in Windows before performing the upgrade for example)


Return to “Firmware”

Who is online

Users browsing this forum: No registered users and 1 guest